ImageMagick suggested compile options

Before compiling ImageMagick, ensure libjasper-dev is installed, so that you can manipulate JPEG2000 images.

apt install libjasper-dev libpng-dev

./configure --with-modules --with-gslib --with-wmf --with-perl --with-rsvg --with-gvc --enable-hdri

make 
make install

ImageMagick compile errors

libMagickCore.so.6: cannot open shared object file: No such file or directory

to fix, try:

whereis libMagickCore.so.6

assuming you find it in /usr/local/lib:

ldconfig /usr/local/lib

Leave a Comment