DraftSight for Windows requires upgrade

DraftSight users on Windows need to update to DraftSight ≥ 2017 SP1.

As of March 1, 2017 old versions of Windows DraftSight are unable to start due to an expired certificate.

Tags:

Categories:

Updated:

Leave a Comment